Lee Kelleher


IE View Lite 1.3.2+ not compatible with Firefox 2.0

Posted on

I used all sorts of add-ons and extensions for Firefox, (I’ll get around to writing a blog post on that soon too). Since I do a lot of web-development, I switch between Firefox and Internet Explorer frequently during a build.

To make this easier, I’ve been using Grayson Mixon’s IE View Lite. But with the latest upgrade (version 1.3.2), it broke in Firefox 2.0! (This made me sad) :-(

I’d been holding out for the next upgrade – to see if that would fix the problem… but nothing came.

So I emailed Grayson to see if there was a potential fix in a future release; which he promptly replied:

IE View Lite 1.3.2 and 1.3.3 are Firefox 3 only. If you want to continue using Firefox 2, you should use IE View Lite 1.3.1, the only difference being compatibility updates for Firefox 3 that broke backward compatibility.

I’ve now uninstalled version 1.3.2 – reverting back to 1.3.1 – and everything is good again! (Thanks Grayson).

It does concern me that support was dropped for Firefox 2.0 in favour of version 3 (which is still only in beta) – cutting out a large proportion of the user-base. But I guess once Firefox 3 has shipped, no one will be bothered anyway.